NTP check at startup

Certify pops up a warning at startup that it was not able to confirm the system time. In my case this is correct, all servers use our internal ntp server for synchronisation and access to public ntp servers is blocked.

ctwntp

Getting the popup with the warning every time I start the application is not really useful.

Is it possible to disable the time check? Or can I set the (internal) ntp server somewhere in the config?

Hi, no you can’t disable or configure this currently but I’ll add some sort of option in Settings to disable startup diagnostics. In previous versions we’ve had a lot of support issues involving things like time sync being wrong (pfx build fails because the cert is from the future), disk space running low, temp file exhaustion etc.

1 Like

Actually I think I’ll make the ntp server configurable in the appsettings.json config file, that way you still get the safety of having the check and if you set to to "", it can skip the check completely.

1 Like

This is now configurable in appsettings.json - after you launch the new version and save a change to settings you will see an entry for Ntp Server:

We have the same issue. We are running 5.1.8.0 and there is no line in the appsettings.json file for the NTP server.

You need to change a setting from the Settings tab. The appsettings.json will then be updated to include the ntpserver setting:

"NtpServer": "pool.ntp.org"

1 Like

Btw, in the next version this is changing to a warning message in the right hand side startup pane so that it’s less intrusive.