Validating Error - key doesn't match


#1

Dear all,

I’m hosting a small number of domains on my Windows 10 “webserver”. I’ve moved them from an old system, using the existing letsencrypt certificates, which are still valid. After the movement, I tried to receive new certificates with Certifytheweb, to ensure, that all is working as expected.

Unfortunately, I got a key mismatch error on all but one domain. See screenshot attached. I tried to use a different mailaddress and have restartet Certifytheweb, but no success. The test feature from Certifytheweb for all domains results in a success.

Any idea what is going wrong?

Thank you,
cp


#2

Dear all,

I could solve the problem by myself. The problem was, that every domain had two certificates:

www_mydomain_com
mydomain_com

But my DNS settings have a forward from mydomain.com => www_mydomain_com

After I removed mydomain.com from the certification process, all is working without any problems.
I guess the problem was, that the acme-challenge folder was not accessible for mydomain_com

Perhaps this information is useful for you as well.
cp


#3

Hi @centipede when you say that you have a DNS forward, are you using the standard http-01 challenge or are you using a DNS challenge? DNS settings shouldn’t affect http challenges, but they would indeed affect DNS challenges.