2008r2 and new SSL redirecting to domain

I’m new to CTW and struggling.
I have a server (Win 2008r2 with two normal SSL’s bonded to IP) working fine.
Added another IP and trying to use CTW to bind to new IP.
Run through CTW and all seems fine - tested OK
However, the new CTW site now redirects to other SSL site.
No idea why - any pointers most welcome

Found this in the CTW docs
“If you require IP specific bindings (to support legacy non-SNI capable clients etc) the recommended approach is to run your first certificate request with Deployment set to ‘Certificate Store’. You can then manually setup the https binding in IIS against the website, then set Deployment back to Auto and look at the Preview tab to ensure the next update will apply the binding update you expect.”
Tried this, still no joy…

Hi Ven, you mention that the new SSL ‘redirects’. Do you mean an http redirection (the wrong site loads) or an invalid cert (the wrong cert loads)?

If it’s an http redirect then that’s IIS website config you need to sort out.

If it’s the wrong SSL cert then either your cert or your website is not bound to the IP you think it is.

Edit each of your website https bindings in IIS and confirm for each that they are using the correct IP address (including if you have any ‘default site’ set up).

Failing that use ‘netsh show sslcert’ to determine which active bindings you have.

Also confirm in the Certify Preview tab (deployment section) that the expected target https binding will be updated each time the certificate is renewed.

You can also email me at: support at certifytheweb.com for more detailed support, if you can send screenshots of config etc.

Thanks webprofusion
The wrong cert is being loaded for the domain.
Have emailed over settings
Thanks for assistance

ah, could be school boy error, domain dns not altered from generic server IP to new IP for SSL = whoops - just waiting for the dns to propagate…

all working :slight_smile: - CTW is a great tool and will save ££££
Thank you to the CTW team

1 Like

Great, glad it’s working for you!