App wont open on Server 2012 - JSON error

Hi Folks,

I am getting a JSON error while trying to open the CertifyTheWeb app v3.0.11 on server 2012.

Any ideas where I should start trouble shooting? done the usual uninstall, restart, re-install, but same issue persists.


Hi Ian, thanks for raising this - was the app working for you before this or has it just never worked on this server?

If it’s happening at start up it sounds like it’s problem loading the list of managed sites.

The config is kept in c:\programdata\certify\ so you could start by backing that up and deleting the folder, then restart the Certify SSL Manager service and relaunch the UI, this would start from scratch.

I’m assuming the server has plenty of disk space an that the %temp% location is not too busy (some things start to fail when there are more than 65536 temp files).

Happy days! renaming the Certify folder in C:\Programfiles and restarting Certify did the trick!

Thanks for your help!

Thanks Ian, glad it worked. Did this error happen from a fresh install or were you upgrading from a previous version?

well, I had it installed and it was working well. I got an email advising that one of my certs was about to expire which I thought was strange as the auto renew had been working well. I tried to open it and got the JSON error. I wanted to upgrade to the latest version to let me create a wildcard cert (I still need to work out how to do that!), so I tried an upgrade without removing the original and I still got the error. I then uninstalled it, restarted and re installed and still got the same error. I uninstalled again, went through the registry for references to Certify and removing them, then re installed, but still the same error.

now its going ok, I have lost the config for the sites, but at least its working now. I can set them up again, no problem.

Do you have a guide on how to create a wildcard cert using Certify?

Ah, so what version do you have installed now? Wildcards are part of v4 which is currently only an alpha test version and is not really for production use.

The emails from let’s encrypt regarding renewals can sometime be referring to a slightly different certificate - so say you get a cert for ‘’ then later change that to get a cert for ‘’ and ‘’ as one cert, the original is still seen by Let’s Encrypt as a cert that hasn’t been renewed and they will email you about it.

I have version 3.0.11 installed.

It’s all good. I can wait until v4 is released, although if an Alpha version was available, I would be happy to test it out.

The alpha version is linked here but it would be worth waiting until the beta or final release if you’ve already had problems upgrading!

thats great. I think I will just wait.

Thanks for your help!

Hi guys,

I go the same problem, Certify was working OK for some months, now when I go to “New certificate” I get JSON error and the app closes.

I’ve submitted the JSON erorr via the popup to you, got no feedback yet. I don’t want to lose all my sites configuration by deleting the folder- if possible. Please help! I can paste the JSON here or re-send via the app.

Tested one more thing: renamed the above mentioned folder to Certfy2 and this didn’t heal the problem. “New certificate” still ends with JSON error.

Problem solved!

We use many scripts to manage the websites, and one of our scripts contains this:

appcmd delete site /"%name%"

Since a while this started to leave some dirt in IIS, the site appears with id, and it has totally no settings or details, it is named


and that’s all it has. After cleaning up those remaining dirt Certify started working again!

You may want to handle that in the code if you can reproduce that AppCmd Delete keeps this dirt.

@kempelen glad you got the problem resolved. It sounds like we were struggling to read your IIS config, yes we need to report these errors more clearly.