Cant connect via SSH

I get that error, Ive tried both username and username@server for logins
tried generating a key pem file on the server, but still no luck, not sure what im doing wrong and cant find any documentation on ssh setup

turned out the first error was unrelated to SSH, but still getting login errors, here is the error log:

2024-06-27 13:48:06.150 -06:00 [ERR] SftpClient :: Failed to perform CopyLocalToRemote [servername:22]: Renci.SshNet.Common.SshAuthenticationException: AuthenticationPrompt.Response is null for prompt "Password for user@servername:". You can set this by subscribing to KeyboardInteractiveAuthenticationMethod.AuthenticationPrompt and inspecting the Prompts property of the event args.
   at Renci.SshNet.KeyboardInteractiveAuthenticationMethod.<>c__DisplayClass15_0.<Session_UserAuthenticationInformationRequestReceived>b__0()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at Renci.SshNet.KeyboardInteractiveAuthenticationMethod.Authenticate(Session session)
   at Renci.SshNet.ClientAuthentication.TryAuthenticate(ISession session, AuthenticationState authenticationState, String[] allowedAuthenticationMethods, SshAuthenticationException& authenticationException)
   at Renci.SshNet.ClientAuthentication.Authenticate(IConnectionInfoInternal connectionInfo, ISession session)
   at Renci.SshNet.ConnectionInfo.Authenticate(ISession session, IServiceFactory serviceFactory)
   at Renci.SshNet.Session.Connect()
   at Renci.SshNet.BaseClient.CreateAndConnectSession()
   at Renci.SshNet.BaseClient.Connect()
   at Certify.Providers.Deployment.Core.Shared.SftpClient.CopyLocalToRemote(Dictionary`2 files, ILog log)
2024-06-27 13:48:06.150 -06:00 [ERR] Export failed due to connection or file copy failure. Check log for more information.

Hi James,

What is your SSH configuration, e.g what private key type, what server type/version etc.

Your server seems to be prompting for a password and we’re not providing it.

Its a standard User/password, tried both user, and user@servername as the username, no diferance (connecting to a FreeBSD machine, thou i doubt that matters), not using keys, thou im attempting to set that up (found a walkthrough), will return with results

ok set up keyset, used the default ssh setup that powershell uses with openssh, not sure what that is to be honest, connecting to a FreeBSP server, i can connect fine manually in PS in either SSH or SFTP

if it helps the keys are id_ed(number) think that indicated the key type

1 Like

got it working, closing ticket

1 Like