Certify SSL Manager service not started. Please restart the service

Hi all,
I have the Certify application installed on Server 2012 with SQL server machine.
The installation and configuration worked succesfully for the first time. after opening sometime after, i’ve recieved the error you see below.
Once i started the service manually there was an error of issue accessing a key. (i didn’t do print screen).
I’ve upgraded to latest version, uninstalled and installed - without success.
I’ve also uninstalled and deleted all refrences and history to the app both on the file system and in the registry, and installed it, and i’m having the same error in the UI, however - no errors when running the service.

When i’m trying to open localhost:9696 it’s not accessible.

Can anyone suggest on how to resolve it?

Hi, here’s the troubleshooting guide for the background service:

The cause of this error can vary - does this machine use IIS or is it just SQL Server that’s installed? Out of interest, are you planning to use the cert for Reporting Services?

First of all, check the logs: C:\ProgramData\Certify\logs the service.exceptions.log should have an entry like this:
[10/08/2020 2:45:14 PM] :: Service API bound OK to http://localhost:9696

Then confirm you can reach the API listener on localhost by opening the browser to http://localhost:9696/api/system/appversion

You mentioned localhost:9696 is not accessible but not how you tested?

For most users who see this problem it’s a resolution issue and updating serviceconfig.json to use the local IP address or fully gualified name works (do not open the public firewall for this port to get this working, it’s not required). Then restart the background service and relaunch the UI.

If the problem persists it may be a deeper config problem, especially if http.sys is not yet used by other services on the same machine: https://docs.certifytheweb.com/docs/backgroundservice#enable-http-listener-ip-address