Could not verify URL is accessible

I was using Certify SSL on my windows Server + IIS, without any trouble, but since some time before whenever I want to create SSL or re-new for any of my websites, I receive this error:

Could not verify URL is accessible:

Hi, before the app performs a full certificate order it attempts to check if anything will cause the http validation to fail (i.e if your website is not public or not responding on http port 80 ). This error says it couldn’t communicate with your server over port 80, but it shouldn’t prevent the certificate request proceeding (it’s just a test).

You can disable this check on the Authorization tab > http validation > uncheck ‘Perform challenge response config checks’.

However please not that if your server is not responding to the config checks it may also fail validation when Let’s Encrypt try to validate your server. In addition, Le’ts Encrypt recently started ‘multi-point’ validation where they check your http response from different network locations, so if for instance you block some countries from accessing your site you may also be blocking validation.

If you need help fixing anything please post your log file here, or consider trying DNS validation instead of http.