Error on Deploy to nginx

Overall, the Test succeeds. However, in attempting to test the Deploy to nginx Task, it errors out. I’ve included a screenshot of the paths dialog.

Note, I’m trying this with my existing cert.

Not certain, but it may be due to my path?

You’re working locally on windows, so the file path is windows style and needs the drive letter e.g. C:\ssl\ - the same dialog can be used to remotely deploy to linux etc which is what the example paths are showing you.

If you have only clicked “Test” so far and not “Request Certificate” then you don’t yet have a certificate file to export to these locations, I think in my other forum post I described getting your certificate order to work first, then figure out the nginx part, so you should do that - that way you have an actual cert to work with for your deployment steps.

1 Like

To clarify, you may well have an existing certificate, but it’s not one managed by Certify so it doesn’t know anything about it. Certify works with PFX files (and exports to PEM etc as part of this deployment task).

A note about “output path for full chain” - this file is your full cert + intermediates chain and is probably the file you want to refer to in your nginx config (along with the key file).

1 Like

First, thank you @webprofusion for all your input… much appreciated.

Upon correcting the paths and clearing that directory, another run of that specific Task and it succeeded.

I had attempted a ‘Request Cert’, however, it gave me a warning about requesting cert from same auth too many times. Anyhow, the process must have ‘deployed’ my existing cert to the directory… don’t know, just guessing here.

In the Status section, it indicates an Active Cert w/ today’s renewal date. A status I was not able to achieve via Certbot :roll_eyes:


Great, glad you got it working. The warning about requesting a cert too many times is there to make sure you don’t hit a rate limit with Let’s Encrypt but you can ignore it if you want to proceed anyway. Generally If you do already have a cert (the request with Let’s Encrypt worked ok) and you just want to try out a deployment task then you can hit the play button next to the task.

I’m still not sure why certbot didn’t work for you (nginx not cleanly shutting down maybe) - you may find you need to add a Pre-Request task here to stop nginx before you proceed with the cert renewal, otherwise Certify may not be able to use port 80 for the http validation step.

You will find that the community edition of Certify has hard limit of 10 different managed certificates (with a nag message after the first few) but that should be enough for your sites - you can even just get one cert to cover all your domains rather than getting a cert per site.

1 Like