Failed to copy destination file

I tried to setup a task to export certificates for use with Apache (cert + key) however no matter how i configure it, i get an error “Failed to copy to destination file: …”
It seems it only allows to save in the root of hard disks - sub directories or network drives fail.

@Developers, am i misunderstanding how this should work, or is it a bug ?

I tried various version, where 1. is the one i really want.

  1. With the following path: w:\certs_and_keys\\certificate.crt where w: is a network drive - This failed with above error.

  2. With the following path: w:\certificate.crt where w: is a network drive - This failed with above error.

  3. With the following path: d:\certs_and_keys\\certificate.crt where d: is a normal hard disk - This failed with above error.

  4. With the following path: d:\certificate.crt where d: is a network drive - This is the only one that worked successfully.


The Certify background service runs as Local System which by default won’t have network copy permissions on your network and it won’t know about mapped drives because user profiles are not loaded in the process (the service is not running as your account).

I would suggest setting Authentication to Windows Network, set Credentials to a valid network user, and set the path to a UNC path to the share e.g. \\SERVERNAME\share\\certificate.crt (whatever W: maps to). Note that destination folders must exists, the app won’t create folders for you, just the resulting file.

Hello again,

Awesome with the fast response :grinning:

I tried setting it up as you suggested, however it results in a NullReferenceException and nothing gets saved - see picture.

The filepaths are set to:
Cert: \\\www\certs_and_keys\\certificate.crt
Key: \\\www\certs_and_keys\\private.key

For credentials i put the username/password for the network share. The domain field is blank.

Thanks, I think you have found a bug in the validation step of the Windows Network version of the export. It’s trying to check for the UNC path even on empty items. A workaround would be to specifying an output file for all the Output filepath parameters, we’ll get that fixed in the next update.

Note that for Apache (and most other things) you generally need the Full Chain and the Key, as the “cert” file only includes your actual cert without all the required intermediate CA certs.

1 Like

I can confirm, that after filling out all the fields, that all 4 certificate files get exported as expected :smiley:

Thanks for excellent support in this matter 5/5 :star::star::star::star::star:

Great, glad that worked. We will be releasing v6.0.14 today or tomorrow which includes a fix for this.