IIS management service can no longer be started

Hello everyone here in the forum

I have a problem that the IIS administration service can no longer be started.
I ran the software in my virtual environment for testing, after moving the server to my VMWare environment, the IIS admin service fails to start.

I set up a new server without your software for testing purposes and then moved the server back to the VMware and then the IIS management service can be started.

Does anyone have an idea where the error could be?

Hyper-V 2019 test environment
VMWare ESxi production environment

It appears your machine key is corrupted. This is definitely unrelated to Certify The Web and I would suggest starting with a new VM.


thanks for the very quick reply!
yeah that’s what i found out too.

But the Certifytheweb program changes something in the system.
As already described, this error only occurs if I have installed certify the web.
I have 2 completely identical VMs
VM1 with certify the web program
VM2 without certify the web program

If I move VM1 then I get the described error.
When I move VM2 then I don’t get any error.

So the program has to change something here?
Reinstalling doesn’t help either.
I also uninstalled the certify the web in VM1 and then moved it, and the same error occurs here.

Both VMs (VM1 and VM2) are complete new installations of W2012R2 for testing.

is something changed on the folder rights?

Thanks, I actually didn’t properly read the part about moving between hyper-v and vmware.

Certify The Web only installs itself to C:\Program Files\CertifyTheWeb and registers the Certify service to run as Local System. It does perform some basic maintenance on the Local Machine certificate store related to trusted root certificates, but that’s largely unrelated to the machine keys etc. It doesn’t do anything to IIS configuration itself until you attempt to apply a certificate (when it updates IIS bindings). It’s possible that some windows features (like http.sys) are affected differently after the app is running as it registers an http API listener on port 9696. Does IIS Admin start if you stop the Certify background service?

Do hyper-v and vmware install their own extensions to the VM and if so does something need to be removed or disabled after the machine is moved? Is something resetting the machine keys for Local System?

Does it help if you stop all IIS related services before moving the machine? Can you uninstall IIS and re-install to fix?

We haven’t had any reports of this issue but personally I can’t see any reason why anything specific to Certify The Web would result in this failure.