Multiple SSL Certificate issue

We have added multiple ssl domain in same server, but it seems to be not working. We have getting this error

We have added single domain its working fine, we have choosen same www root folder for another domain file not found issue getting. Can you please explain anyone ASAP.


Are you on the latest v4 version or is this still v3?

When Let’s Encrypt try to validate you domain they check the ‘challenge response’ file that we automatically create under your website in the /.well-known/acme-challenge path - you can see that path in the screenshot and it’s saying that file returns a 404 error. That’s usually either because the file is being created at a different path to the one the website is serving, or your content management system is preventing the file being served. Sometime this mean you need to provide special config in your parent application to allow the request through to that path. As a test, you should be able to browse to without getting a 404 error.

By default v4 has a new http challenge server that helps with this sort of thing by avoiding the need to configure IIS specially.

we are using v4

Thanks. Under Settings have you got Enable Http Challenge Server checked?

If you do a test (in the managed certificate settings, click Test) what’s the result?

yes it is defaultly checked in as enable

Ok, so from that it should work perfectly, but clearly that’s not the case.

I’m running low on suggestions, for some reason your IIS server is responding and therefore your content management system is responding with the 404 page. You could try restarting the Certify background service and also end any Certify tasks if there are any hung processes.

Do you run any other web server processes (like Apache or nginx) on the same server - that could prevent the http challenge server binding although I would expect the Test to fail if that was the case.

Is there anything running in front of the website like cloudflare or a load balancer?

i cant understand what mentioned above…but after testing(he managed certificate settings, click Test) it shows now

1 Like