No listed websites?


#1

Hello,

I’m trying to run this on server 2012 however when creating a new certificate, or modifying an existing one, under the certificate domains section, there are no websites listed to choose from.

I’ve gone through and have successfully requested certificates, but because the Certify application sees no sites it won’t deploy the certificates to any sites.

Is there some setting, or permissions I am missing to enable this?

2018-12-21%2006_37_16-Window

Thanks.


#2

Hi, do you have any other website control panel software installed?

Sometimes there are issues if an app installs its own version of the ms web administration DLL into the global assembly cache.

I’m assuming IIS lists the websites with no problems.


#3

The only things I can think that may have installed it’s own webadministration DLL would be the webadministration powershell module, or the Web Deploy and Web Platform Installer programs. I’ll try removing Web Deploy and the Web Platform Installer and see if that gets it working.

IIS lists the websites with no problems.

Thanks again for the help.


#4

I’ve gotten it working and listing sites on a test 2012 server, the only difference I’m seeing is I’m using .NET 4.7.2 on the test. I’ll be updating .NET on the other servers and restarting them off hours, I’ll post again to let anyone who is interested know if it worked or not.


#5

Thanks, yes the web deploy components etc are very standard so it won’t be them. The inability to list IIS sites is very rare but has come up before.


#6

I was wrong, the .NET version was up to date. Problem still persists.


#7

I presume this is all just a default install and (background service running as local system) and that there is no custom application installed on the server (it’s just for IIS websites).

Where I’ve see this before the server has had an application to manage website setup of customers (e.g a cpanel type thing, can’t remember the product name) installed, even though it may no longer be being used.


#8

Another thing to check is C:\Windows\System32\inetsrv\config\applicationHost.config - the normal location for the IIS configuration. Does that file appear to contain your websites?


#9

Ya, we don’t use any sort of cpanel like management software.

From what I can tell it is just effecting these two systems which happen to both be cloned from the same source so that makes sense. I’ve looked in the applicationHost.config file, from what I can tell every site is listed there.

This server is running some legacy sites, I’ve attached the installed programs however I don’t think there’s going to be anything there that effects it.

Could the system having been renamed after the web server was cloned be effecting this?



#10

Hi,

If you do a windows explorer search under C:\Windows\Microsoft.NET\assembly for Microsoft.Web.Administration do you get any results? If so this would be the conflicting version of the microsoft iis administration dll, however it would have been installed by an app that you possible rely on so I can’t advise removing it.

The other possibility is that the SYSTEM account (which the certify background service runs as) does not have permission to query the required parts of the file system or registry, but they would have had to have been actively removed for that to be the case and would have to be diagnosed using sysinterals Process Monitor or a similar sysinternals app to see what is being denied.


#11

I got it, this server was originally a giant mess that was split off into two separate servers. Half the sites on this server were empty, after removing those the application is working as intended. Thank you for all the help.

I wonder if empty sites mess with Certify’s ability to list sites after that point.

gotit


#12

Providing a bit more info, what I’m referring to as an empty site looks like this:

It also has no bindings.


#13

Ah, that’s interesting. Sites with no path or app pool etc usually means a corrupted IIS metabase, or one that was copied from elsewhere and refers to app pools etc that don’t exist. So it sounds like you’ve solved it!