Password in SSL certificate

Is there a way to require a password for my certificates?
Can they be made with a password so that when installed a password is required to import?

Currently the password in the pfx is blank, however this feature is planned in the very near future (a default password and an optional per-certificate password).

Has this feature been added? If so, how do I set the password?

Hi, no the feature is not available yet but preliminary support was added to v5 beta yesterday and this will be released shortly.

There is still some work to be done to be able to choose the stored credential for the pfx password in the UI (we don’t use unencrypted passwords) and a testing phase for the feature.

In the current version (v4) you could optionally use scripting to re-import the PFX with a password using openssl etc but if it’s not urgent I’d wait for the feature in v5.

1 Like

I have version 5.0.12 and I’m not seeing an option for a password still, am I missing it somewhere or is it not available still? Thanks!

Hi Dave, still planned for a future release (next week or the following release after that), it can technically be set in config but there is no UI for it yet.

See the release candidate Version 5.1.0 (Release Candidate) testing

This feature can be enabled as a preview under Settings, note that some things like deployment tasks are not yet fully aware of the PFX password etc so there is more work to do if you use those.

1 Like

Is there an open GitHub issue that I could follow to get notified when custom PFX passwords have been implemented for deployment tasks? I did a search but couldn’t find one. I’m looking to use the custom password with a deployment to a Central Certificate Store.


So in the update, export to CCS will just work as normal but you won’t be able to specify a different password for the exported (copied) PFX - it’ll just have the same password you’ve already set rather than a different one just for the CCS copy.

v5.1.3 has been released now with the UI fix to show the PFX password selection options.

The option is enabled under Settings > UI Settings > Custom PFX/Private Key password then relaunch UI and choose PFX password credentials under Certify > Advanced > Signing & Security.

1 Like

Thanks for clarifying that and for the quick fix! I’ve had a chance to test it out this morning and it’s working perfectly. I’ve got some more testing to do, but assuming all goes well, I’ll definitely be buying a license. You guys have created an excellent utility!

1 Like