PowerShell 5.0 - Windows Server 2012 R2

Hi,

Recently upgraded my server in-place to windows server 2012 R2. Following the upgrade I get the error notice to install PowerShell 5.0 and I can’t add anything new.

I have tried to find PowerShell 5.0 but it doesn’t appear to be available. I downloaded PowerShell 5.1 and when I try to install it my server says it doesn’t apply to my server and aborts the installation.

FYI - the error message I receive from certifytheweb.com app says to visit:
https://docs.microsoft.com/en-us/powershell/scripting/windows-powershell/install/windows-powershell-system-requirements

When I visit the above page it says to install version 5.1 for server 2012 R2

When I try to install version 5.1 I get a system error that says this windows update does not apply to your system.

I am typically pretty good at debugging things on my server but this has me stumped.

Any thoughts or ideas on how to resolve this issue would be greatly appreciated.

Thanks,
Pat

Hi Pat,

If you’re not using any powershell scripting or extra deployment tasks then it won’t matter, the basic functionality of requesting and renewing certificates and applying them to IIS doesn’t use powershell but many of the extra deployment tasks (and scripting etc) do.

I presume this is the install you’ve tried: https://www.microsoft.com/en-us/download/details.aspx?id=54616

You may have to open a support ticket with microsoft if you want to proceed with upgrading powershell on that server. I particularly recommend migrating your workload to an entirely new server if you can (even as a test) because documenting that process frees you from having to maintain an old server and means you can upgrade to new servers more easily.