This site can’t be reached took too long to respond

I host my website on my home computer
Windows 10

I manage the website using inetmgr, NO-IP, CertifyTheWeb and LetsEncrypt. To resolve an unknown issue I recently re-loaded Win10 over the internet from Microsoft. Since then my website has become inaccessible…

This site can’t be reached took too long to respond.

The 403 (Forbidden) status code indicates that the server understood the request but refuses to authorize it…If authentication credentials were provided in the request, the server considers them insufficient to grant access.

I tried these suggested things, problem still exists…
Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics

I ran these to reset the internet connection…
ipconfig /flushdns
netsh winsock reset
netsh int ip reset

I re-installed iis.

I checked the port forward of 80 and 443, the redirect of http to https, allowed Chrome thru the firewall, removed all Chrome add ons, tried MS Edge as an alternative browser, not using proxy, …

I am hoping that there is some Certify the Web setup process that I need to re-do because I re-loaded Win 10.

The current Certify the Web situation is…

Check for updates:
using latest version

All tests completed OK

There seems to be a contradiction between these two…

Managed Certificates [in red]:
No Current certificate

Renew All: Success [in green]
Skipping Renewal, existing certificate OK.

Any assistance appreciated :slight_smile:

Hi Mick,

If you can avoid hosting your website on your home computer that would be for the best overall as you are letting anything on the internet attempt to communicate directly with your home network, which has some risk.

The 403 is probably that the file system permissions don’t allow IIS (your web server) to read the files.

The 403 error is nothign to do with Certify The Web - all the app does if renew certificate in the machine certificate store then update the https binding in your IIS website, if it can find it (matching on the hostname).

I don’t understand the “no current certificate” issue though (try just closing the app and opening it again in case something got out of sync in the UI). Once you get your website working over http (tcp port 80) just delete that managed certificate in the app and add it again.