Unable To Create A Register Contact On A Virtual Machine

If I try to create a register contact on a virtual machine, it would get this dialog with message “Failed to register account with certificate authority: A task was cancelled”, after a long process period. What could be the cause to this, and how can this be solved?
I’m grateful for any assistance.


First time I’ve seen that error! Check that the Certify background service is running ok and try restarting it. Ensure that outgoing https calls are allowed through your firewall as the app needs to talks to the let’s encrypt API over https.

There was also some Let’s Encrypt API maintenance done a few hours ago: https://letsencrypt.status.io/pages/history/55957a99e800baa4470002da

I can confirm that we are getting the same error: server 2016, with full internet access. brand new install and we cant register a contact. uninstall/reinstall, triple checking services and so on, doesnt seem to help. anyone got any ideas?

Exact same error message? Try using the desktop browser to go to https://acme-v02.api.letsencrypt.org/ - if that doesn’t work then that would be the obvious reason but I’ll also test on a new machine myself.

Out of interest which cloud VM provider are you all using?

I can confirm there is no general issue and that I can download the latest version and add a new Let’s Encrypt account on Server 2016 and 2019 (via AWS EC2).

I restarted the ec2 instance and added https outbound rule in the security group. I guess these steps solved the problem because it worked thereafter.

Thanks to all. I appreciate your support.

1 Like

Fixed this by adding a outbound block rule to windows firewall, for the proxy server address. Proxy was disabled, netstat proxy settings were correct (direct outbound access), but somehow CertifySSLmanager.service.exe was still somehow getting proxy settings? No idea how.

Thanks, Certify does not currently support Proxies, although users have been able to get them to work. Some proxies work transparently in windows, some don’t.

I’m not sure what your exact problem is but it’s important to understand that, similar to Mapped Network Drives, proxy settings are per-user and a service using the SYSTEM account won’t follow what an interactive user sets up.

1 Like