Upgrade to v4.1.6

Hi,

I’m new here and I would like to know how to upgrade my Certify v2.0.11 to v4.1.6, because I recieved an email about ACMEv1 deprecation.

Thanks in advance!

Hi, as that’s quite a big jump I’d backup your C:\ProgramData\Certify folder before upgrading, then download and install the latest version from https://certifytheweb.com

If you are on Server 2008 (before 2008 R2 SP1) you may not be able to upgrade. We currently require .net framework 4.6.2 or higher, so you need to check you have that installed first.

I have the same problem. Trying to install version 4.x tells me that a previous 32bit installation needs to be uninstalled. Curretnly I have the version 2.0x installed.

I didn’t create the first installation.
Do I need to register the certificates again?
Or are they detected by the new installation?
How about the advanced settings?

I was able to install the new version (v4.x), and it uninstalled the old version (v2.x) for me, but it does not show any of my certificates. It must not have imported the old configuration. How can I get that imported?

Hi, if you check your C:\ProgramData\Certify folder that’s where settings are kept. In 2.x the managed certificates were kept in a file called manageditems.json and in v3 onwards this is upgraded to a manageditems.db file (an SQL Lite database). To re-attempt the settings upgrade you could restore your manageditems.json file (there should be a manageditems.json.bak file if the original was upgraded) and delete manageditems.db, then restart the Certify background service and relaunch the app, which should attempt to upgrade the settings again.

This problem hasn’t been reported before so I wondered if there is something different about your system (settings path?).

If the problem persists we’ll need a backup of your C:\ProgramData\Certify folder to see why the upgrade isn’t happening (email support at certifytheweb.com)

I attempted your procedure and got the same result. I will try emailing support with a copy of my folder.

Same for me. Deleteding the DB file and recopying the json file didn’t work, No certificates are shown.

Thanks will investigate with info from @edge9421 - the v2.x was last updated in 2017 and there have been many updates since then, if you don’t have many items to upgrade just start new managed certificates instead otherwise email your config as above to support at certifytheweb.com

@edge9421 @xMRi I can confirm there is a bug in 4.x upgrading the manageditems.json file (converting to manageditems.db). I suspect this wasn’t spotted before because most users went from 2.x to 3.x then 4.x. I’ll see if we can either release a 4.1.7 version or produce a utility to perform the upgrade.

In the meantime if you have less than 10 managed sites I would advise just setting them up again the app.

Thanks for raising the issue. See also https://github.com/webprofusion/certify/issues/484

Thanks for figuring that out. Any idea on a timeframe for the fix? I’m ok with waiting for the fix if it’s not going to be more than a week or so. If it’s going to be longer, I may try the 3.x upgrade then 4.x upgrade as mentioned in that link you provided.

Hi, it looks like we need to do a patch release (first in a year!) for some users who need longer DNS propagation times. I’d expect this soon, possibly before the middle of next week.

We have a much bigger v5 upgrade in the works but that’s further away and will also need this fix included.

v4.1.7 is out now with fixes for DNS propagation and for migration manageditems.json to the newer database format.

If you have previously attempted an upgrade an have an empty list of managed certificates, delete C:\ProgramData\Certify\manageditems.db and rename manageditems.json.bak to manageditems.json and restart the Certfy background service and UI.

Excellent. I will try that now.

I confirmed the patch fixed the import of my manageditems.json. Thanks!

1 Like

Thanks! I finallly upgraded to v4.1.8 and old certificates were imported. But now i wonder if I should renew old certificates.

As you are upgrading from an old version, go to Settings and check if you can see an option for Configure Auto Renew then click this and set the renewal to use Background Service - the old method of using a scheduled task is not supported and the old task would have pointed to the old version of the app anyway and will no longer function. You should monitor to check that certificates are renewing automatically and once everything is confirmed ok you can leave it.

Also check the value for Auto Renewal Interval - this is how many days you want to keep the current certificate for before renewing - the max is 60 days (so that there’s time to alert you to renewal issues before the full 90 day expiry) - 30 days is the default.

You can review how your next renewal will update bindings etc under Preview, you should try renewing one of the managed certificates by clicking Request Certificate.

Hi ! I’ve to upgrade v2.07.34309 32bit version to v4.1.9 64 bit. I would like to be sure of the required step to do:

  1. Uninstall old 32 bit version. The settings will not be removed (is it right ?)
  2. Install the new 64 bit version. The settings from step 1 will be kept (ok ?)

It is reccomended to backup the “c:\program file (x86)\certify” folder. Isn’t it ?

thank you in advice.

Hi, there isn’t a v4.1.9 (currently) so hopefully that’s a typo.

No, backup C:\ProgramData\Certify before you begin (not the prorgram files folder unless you have something custom under there), these settings will be kept but they will be upgraded. Then uninstall the old 32-bit version and install the 64-bit version. You should then see all your migrate managed certificates as normal.

You should then go to Settings in the app and if you can see the Configure Auto Renew option go theere and set it to background service, the scheduled task is no longer used and the old one will point to the old 32-bit app.

Then, check the preview tab on some of your managed certificates to ensure the planned binding updates for the next renewal look fine, then try renewing some certs (just click Request Certificate) to ensure renewals are working ok.

Yes ! I meant v4.1.8.0 64 bit :slight_smile:
Thank you for your instructions. I forgot to backup up the old C:\programdata\certify :frowning: but I think everything went ok.

  1. I uninstalled old 32 bit version
  2. I installed new 64 bit version

well …

  1. Looking at Default Web Site --> Certificate Domanis, I see my migrated certificate. The expiration warning si correct: “Expires in xx days.”.
  2. I think the interface is different from yours … I need to check “Show advanced option”, then select “Other Options”, and I find “Enable Auto Renewal”: it is checked.
  3. In te “Settings” tab I cannot find “background service”, I see:

Auto Renewal Interval Days = 30
Maximum Auto Renewal Requests Per Session = 0 (unlimited)

Enable App Telemetry: cehcked
Enable proxy API for domanin config checks: checked
Ingore stopped IIS sites for new certificates and renewals: cehcked
Enable DNS Validation checks: unchecked
Enable HTTP Challenge Server: checked
Enable Status Reports to Dashboard: checked

that’s all !
thank you very much