Validation of required challenges did not complete successfully. Domain validation failed

Hello together,

I’m a liitle helpless. My Request Certificate process fails. Tests were successfull.
Even the URL works while the process runs - seems that the HTTP Challenge Server works fine. A browser from outside shows

But the domain validation failed.

Any ideas what’s missing?


I can’t say much since the challenge server isn’t running right now, but if you start it again… try asking for diagnostics info.

Sorry - how can I do this? In the settings the Challange Server is enabled.


Hi, when Let’s Encrypt checks your domain it does so from multiple geographic locations, the most common reasons for this type of failure are:

  • You are blocking certain IP ranges or geographic regions
  • Your server resolves internally correctly, but externally it is resolving to something else

Note that if there is a specific reason you need to block requests geographically then you will need to switch to using DNS validation: DNS Validation (dns-01) | Certify The Web Docs

Thanks for that. I used manual DNS Validation and it worked fine.

1 Like

Ok, long term you probably need to use an automated DNS api instead of manual, as otherwise you will need to perform manual DNS updates for each renewal.

Great thanks.

I changed to Posh-ACME - our provider was listed there and it works fine!

A last question: How can I delete certain credentials in the Authorization Settings? I can only find a New-button but no one for deleting existing ones.

HI, you can replace or delete credentials under the main app Settings > Stored Credentials.

Yes that worked - Thanks!

1 Like