How FTP auto update follow latest renew SSL Cert


I have same this 1106 problem, but I can’t solved it. Guide to me please.

I want to FTP SSL Cert. update follow renew SSL cert from CertifytheWeb. (my main domain and my mail subdomain are correct updates)

Below image is my setting in Certifytheweb and IIS manager binding for FTP

Thank you

Hi, for the app to recognise that your binding should match that certificate you need to set the hostname in your ftp binding (so for instance set the Host Name to “”, for instance).


Under the “Deployment Mode” tab, set the Deployment Mode to Single Site and leave all the other options at the default setting. This is because the “Auto” mode does not match ftp sites.

You should then see on the “Preview” tab that the app will plan to update the ftp binding.


I set th Host Name in FTP Binding and chane Deployment Mode to Single Site but I have some problem.(such main web domain and sub domain do not update to lastest SSL Cert after I press Request Certificata and I can not connect FTP Server form FTP client software)
I explain in below image. Please help.

Thank you


Regarding your main site va your ftp site, it’s OK to have 2 managed certificates (one for your FTP site and one for the website). Your FTP site doesn’t even need to use a wildcard if the ftp site is always called, so you could set the domain for the certificate to be so you can tell the difference between the two certificates.

The “Single Site” choice targets the specific IIS site you have selected in the dropdown, which in this case is your FTP site.

Regarding Filezilla not being able to connect to your ftp site I’m afraid I don’t regularly use FTP or Filezilla so I can’t provide much advice on that but I do notice that “” does not resolve, so there is probably no DNS entry.


I actually didn’t want wildcard. But the goal that I want to access files in my server via FTP Client software(such Filezilla, WSFTP, etc…) but require SSL Cert. This below image is normally usage but if renew SSL happend the FTP SSL Certificate setting does not make improvements according to the changes of the main renew SSL. Makes me have to update with myself every time there is an renew SSL.

Please guide me to set it up for anythings to do this.

Thank you

Certificate binding updates performed by this app relate directly to hostnames. If you want your ftp site to just be then just use that as the hostname in the ftp binding?


So I need to binding a hostname for FTP (such
Brings me back to the first problem. I will not be able to connect the FTP Server from FTP client softwary by the host name of the server or the IP address number of the server.

Should I have to do something more within the DNS manager? To be able to connect the FTP server normally. Guide me please.

Thank you

Your ftp binding can be if you want it to be. The ftp binding does not need to have ftp. in the name, that’s just a convention I assumed you were following. So you can just set your hostname to in the ftp binding.

Note that certificates cannot contain IP addresses so you will not be able to use TLS to connect to ftp using only the IP address, this is just a limitation of Let’s Encrypt certificates in general.

Now, I binding FTP with But as a result, I can’t conect with FTP Server through the FTP client program.
Below image is my binding with host name : and result on FTP client software (Connection Fail).

And if I remove the Host Name on FTP binding, I can connect to FTP server with FTP client software normally of both( FTP Client Seftware when set Host : or Server IP address)

What should I do to be able to connect if binding host name is set up?

Thank you.

The error message suggests that the certificate has not been enabled for this binding in IIS.


I have already binded it up. As the picture I’ve shown you.

If I’m not doing everything at any point, please advise me where I need to fix it.

Thank you

It seems like there is no certificate enabled for this ftp site - if I try the linux command openssl s_client -connect it should respond with a TLS handshake but doesn’t.

Sorry, I don’t think I know enough about FTP configuration to help you more.


I’m sorry Now I have found the point of error. It happened to set up the FTP connection within FTT Client Software at User input.
Previously, I didn’t binding to the hostname, I just put a normal username and it works. But when binding the hostname is inserted, I have to put the servername along with the username as shown in the picture.


Thank you for your support

1 Like

Great, glad you got it working.