There is no matching ACME account for the currently selected Certificate Authority

Hi All,

I’m receiving this error message I’m not quite sure I understand it is trying to tell me…

2020-09-01 05:15:11.635 -07:00 [ERR] Failed to match ACME account for managed certificate. 
Cannot continue request. :: kovatchcastings.us CA: letsencrypt.org [Production]
2020-09-01 05:15:11.636 -07:00 [INF] There is no matching ACME account for the currently 
selected Certificate Authority. Check you have added a Production account for the CA under the app 
Settings.
2020-09-01 05:15:11.656 -07:00 [ERR] Failed to match ACME account for managed certificate. 
Cannot continue request. :: kovatchcastings.us CA: letsencrypt.org [Production]
2020-09-01 05:15:12.308 -07:00 [INF] There is no matching ACME account for the currently 
selected Certificate Authority. Check you have added a Production account for the CA under the app 
Settings.
2020-09-01 05:15:12.336 -07:00 [ERR] Failed to match ACME account for managed certificate. 
Cannot continue request. :: kovatchcastings.us CA: letsencrypt.org [Production]

Certify needs to be configured with an account that Let’s Encrypt(LE) knows about. You just give Certify an email address LE will use for expiration notices and LE will give Certify an auth token to keep.

You may have accidentally created a Staging (test) account when you set up the app - this is only useful if you are trying to test your setup and want to avoid affecting your Let’s Encrypt rate limits. Add a new production Let’s Encrypt account under Settings > Certificate Authorities as @jljtgr suggested.

@webprofusion and @jljtgr

Thank you both for your help, it was the staging that was causing the problem…